April 05, 2006
HMPassphrase 1.1

I fixed a bug in my Movable Type anti-spam plugin, HMPassphrase (previous post) that prevented the junk scoring mode from working.

I had a few people email me to say it wasn't working for them, but it was kind of hard to debug until I hand-patched a bug in Movable Type itself that caused it to emit useless error messages when plugins failed.

HMPassphrase is the most effective anti-spam plugin for Movable Type that I know of.

Posted by jjwiseman at April 05, 2006 05:06 PM

John -- I just installed HMPassphrase and I'm so eager to get it up and running (I'm getting roughly 1500 spam comments a day, most, but not all, being caught by MT's other tools).

But I'm stalled at the point where I add the input field to my comments page.

Can you point me to an example I can check?

Thanks -- and thanks for HMPassphrase...

Posted by: Joseph Holmes on April 11, 2006 08:01 AM

Update: I kept trying, dug around, and finally figured out how to create the input field. No need for further follow-up.

And it's working great!

Posted by: Joseph Holmes on April 11, 2006 01:16 PM

Thanks for the fix.
I had installed the old version just a couple days earlier.

Now it's working fine!

Posted by: Steve Sumner on April 12, 2006 09:09 AM

I tried downloading it and got the following:

Proxy Error
The proxy server received an invalid response from an upstream server.

The proxy server could not handle the request GET /HMPASSPHRASE/WIKI/DESCRIPTION.

Reason: Could not connect to remote machine: Connection refused

Apache/1.3.33 Server at projects.heavymeta.org Port 80

Posted by: Tony Spencer on May 2, 2006 03:10 PM

Sorry for the problem, Tony. I restarted it about 10 minutes after you posted your comment.

Posted by: John Wiseman on May 3, 2006 12:19 PM

Hi John,

I'm excited to try out HMPassphrase! Unfortunately, I seem to be having the same problem as Tony did.

Thanks in advance for your help!


Posted by: Ben on May 31, 2006 10:59 AM

Ben, I apologize. The server occasionally goes down, and sometimes it takes me a day or two to notice. It should be up now.

Posted by: John Wiseman on June 2, 2006 10:40 AM

Got it! Thanks so much!

Posted by: Ben on June 5, 2006 01:56 PM

Hi Ben,

Sorry to be a pain, but I cannot find the space to add the field. I can find every comment template except for the comment section. Any ideas?

It's the same problem as Joseph - I am just not sure how he solved it!



Posted by: Claudia on June 13, 2006 04:35 PM

Hi John. Your server is down again. When will the plugin be available again? Thanks in advance. Seb

Posted by: Seb on July 2, 2006 09:34 AM
Post a comment

Email Address:


Unless you answer this question, your comment will be classified as spam and will not be posted.
(I'll give you a hint: the answer is “lisp”.)


Remember info?